Hi, On Thu, Jan 28, 2021 at 09:57:19PM +0100, Lukas Wunner wrote: > On Thu, Jan 28, 2021 at 03:29:31PM +0300, Mika Westerberg wrote: > > /** > > - * tb_drom_read - copy drom to sw->drom and parse it > > + * tb_drom_read() - Copy DROM to sw->drom and parse it > > + * @sw: Router whose DROM to read and parse > > + * > > + * This function reads router DROM and if successful parses the entries and > > + * populates the fields in @sw accordingly. Can be called for any router > > + * generation. > > + * > > + * Returns %0 in case of success and negative errno otherwise. > > */ > > int tb_drom_read(struct tb_switch *sw) > > { > > I'm confused by the terminology change of "router" vs. "switch". > Is this change mandated by USB4? Not mandated. > The parameter is a tb_switch, so calling it a router looks a little odd. Right. I'm trying to use the "new" terminology in the comments so that people reading those might be able to match it better with the spec. Even though in code we still have tb_switch, tb_port etc. Perhaps we can mention in kernel-docs of struct tb_switch and others the corresponding USB4 spec term?