On Thu, Jun 11, 2020 at 04:36:29PM +0800, Ramuthevar, Vadivel MuruganX wrote: > On 11/6/2020 4:12 pm, Andy Shevchenko wrote: > > On Thu, Jun 11, 2020 at 10:12:46AM +0800, Ramuthevar,Vadivel MuruganX wrote: > > > From: Ramuthevar Vadivel Murugan <vadivel.muruganx.ramuthevar@xxxxxxxxxxxxxxx> ... > > > + ret = readl_poll_timeout(ctrl1, val, val & SRAM_INIT_DONE, > > > + 10, 10 * 1000); > exceeds more than 80 characters, so checkpatch throws warnings, to avoid > that move to next line. > > On one line easier to read. It's 82 characters. It's fine. > > > + if (ret) { > > > + dev_err(ta->phy.dev, "SRAM init failed, 0x%x\n", val); > > > + return ret; > > > + } ... > > > + int ret = 0; > > > > Assignment is redundant. > so you mean , should be declared as > int ret; > right? Right. ... > > > + dev_info(ta->phy.dev, "connected%s\n", > > > + flipped ? " flipped" : ""); > > > > One line. > exceeds more than 80 characters, so checkpatch throw warnings, to avoid that > moved to next line. It's fine to have on one line. And by the way, try new checkpatch. -- With Best Regards, Andy Shevchenko