On Sat, May 02, 2009 at 12:55:36PM +0530, Viral Mehta wrote: > > Viral Mehta wrote: >> >> >>> + >>> >>> /*-------------------------------------------------------------------------*/ >>> >>> >>> /* >>> @@ -426,7 +488,9 @@ static int rh_call_control (struct usb_hcd *hcd, >>> struct urb *urb) >>> case DeviceRequest | USB_REQ_GET_DESCRIPTOR: >>> switch (wValue & 0xff00) { >>> case USB_DT_DEVICE << 8: >>> - if (hcd->driver->flags & HCD_USB2) >>> + if (hcd->driver->flags & HCD_USB3) >>> + bufp = usb3_rh_dev_descriptor; >>> + else if (hcd->driver->flags & HCD_USB2) >>> bufp = usb2_rh_dev_descriptor; >>> else if (hcd->driver->flags & HCD_USB11) >>> bufp = usb11_rh_dev_descriptor; >>> >> I think better to replace "if ... else if... else" with switch case as >> you did in patch [06/23] > You think its not a good idea ? or you want me to drop a patch to do this ? No, it's probably a good idea. Feel free to send a patch to fix it. :) Sarah Sharp -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html