Hi Grigor, sorry for misusing the cover letter for my comments, but i didn't received all patches. > Grigor Tovmasyan <Grigor.Tovmasyan@xxxxxxxxxxxx> hat am 26. Dezember 2017 um 12:21 geschrieben: > > > ... > > Gevorg Sahakyan (1): > usb: dwc2: Remove version check in GSNPSID > > Grigor Tovmasyan (4): > usb: dwc2: Delete unused functionality > usb: dwc2: Make function static Better subject: Make dwc2_force_mode static > usb: dwc2: Add call_gadget() function call > usb: dwc2: Add core state checking > > John Youn (2): > usb: dwc2: Enable LPM > usb: dwc2: Enable power down > > Minas Harutyunyan (5): > usb: dwc2: Change TxFIFO and RxFIFO flushing flow I don't how critical this patch is, because it doesn't mention any consequences. In case it's critical this patch should be in a separate patch series as Greg mentioned. If not, i would prefer to apply "[PATCH v3 44/49] usb: dwc2: Update bit polling functionality" before this patch so we do not need to review code which is removed later in the series. > usb: dwc2: hcd: Fix host channel halt flow > usb: dwc2: Add safety check for STSPHSERCVD intr > usb: dwc2: host: Fix transaction errors in host mode > usb: dwc2: Add safety check in setting of descriptor chain pointers > > Razmik Karapetyan (10): > usb: dwc2: Set AHB burst size to INCR The usage hsotg->params.ahbcfg instead of the defines is a unintended fix for BCM2835. According to the BCM2835 datasheet this register have a different definition. So i like to see this split up. > usb: dwc2: Remove unnecessary debug prints > usb: dwc2: Define PCGCCTL1 register in hw.h > usb: dwc2: Define Active Clock Gating support bit in GHWCFG4 I think this one should be merged into the first patch which uses this define. > usb: dwc2: Add dwc2_enable_acg function > usb: dwc2: Backup and restore PCGCCTL1 register > usb: dwc2: Update dwc2_handle_incomplete_isoc_in() function > usb: dwc2: Update dwc2_handle_incomplete_isoc_out() function > usb: dwc2: Update GINTSTS_GOUTNAKEFF interrupt handling > usb: dwc2: Rename function names Better subject: Improve bit function names > > Sevak Arakelyan (7): > usb: dwc2: Fix GLPMCFG... definitions Better subject: Rename GLPMCFG... definitions and please fix the typo "definitoins" in the commit log > usb: dwc2: Add core parameters for LPM support > usb: dwc2: gadget: Add functionality to exit from LPM L1 state > usb: dwc2: gadget: LPM interrupt handler > usb: dwc2: Enable LPM Transaction Received interrupt Would be nice to extend the commit log, why this is necessary. > usb: dwc2: gadget: Configure the core to enable LPM > usb: dwc2: Update bit polling functionality > > Vardan Mikayelyan (20): > usb: dwc2: eliminate irq parameter from dwc2_gadget_init > usb: dwc2: Force mode optimizations > usb: dwc2: Rename hibernation to partial_power_down > usb: dwc2: Add hibernation field into dwc2_hw_params > usb: dwc2: gadget: Moved dtxfsiz backup array place > usb: dwc2: gadget: Fix dwc2_restore_device_registers > usb: dwc2: core: Add hibernated flag This commit log isn't very descriptive. Why is this flag necessary? Happy New Year Stefan -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html