Hi Johan, Thanks for your review ! Here is the v2 of the serie. I didn't resubmit patches related to the switch to generic implementation (open, close, read and write). I will work on them later when this first batch will be pushed. Thank you, Mathieu Mathieu OTHACEHE (22): usb: serial: ti_usb_3410_5052: Do not use __uX types usb: serial: ti_usb_3410_5052: Remove useless dev_dbg messages usb: serial: ti_usb_3410_5052: Use kzalloc instead of kmalloc usb: serial: ti_usb_3410_5052: Remove useless NULL-testing usb: serial: ti_usb_3410_5052: Use C_X macros instead of c_cflag manipulation usb: serial: ti_usb_3410_5052: Remove unused variables usb: serial: ti_usb_3410_5052: Use macros instead of magic values usb: serial: ti_usb_3410_5052: Remove in_sync and out_sync functions usb: serial: ti_usb_3410_5052: Remove useless tty_wakeup usb: serial: ti_usb_3410_5052: Change ti_write_byte function arguments usb: serial: ti_usb_3410_5052: Do not modify interrupt context usb: serial: ti_usb_3410_5052: Remove usb_serial pointer in ti_port usb: serial: ti_usb_3410_5052: Change ti_get/set_serial_info function arguments usb: serial: ti_usb_3410_5052: Do not set shadow mcr in open callback usb: serial: ti_usb_3410_5052: Check old_termios parameter in set_termios usb: serial: ti_usb_3410_5052: Raise DTR and RTS flags if speed is not null anymore usb: serial: ti_usb_3410_5052: Fix firmware downloading usb: serial: ti_usb_3410_5052: Standardize debug and error messages usb: serial: ti_usb_3410_5052: Use variables for vendor and product usb: serial: ti_usb_3410_5052: Set shadow msr before waking up waiters usb: serial: ti_usb_3410_5052: Add CMSPAR support usb: serial: ti_usb_3410_5052: Fix indentation problems drivers/usb/serial/ti_usb_3410_5052.c | 712 +++++++++++++++++----------------- 1 file changed, 346 insertions(+), 366 deletions(-) -- 2.9.0 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html