Mathieu OTHACEHE <m.othacehe@xxxxxxxxx> writes: > This patch fixes the following coccinelle warnings: > > drivers/usb/serial/mos7840.c:2042:4-10: Move constant to right. > drivers/usb/serial/mos7840.c:2062:16-22: Move constant to right. > > Signed-off-by: Mathieu OTHACEHE <m.othacehe@xxxxxxxxx> > --- > drivers/usb/serial/mos7840.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/usb/serial/mos7840.c b/drivers/usb/serial/mos7840.c > index 8ddc313..982a3fb 100644 > --- a/drivers/usb/serial/mos7840.c > +++ b/drivers/usb/serial/mos7840.c > @@ -2039,7 +2039,7 @@ static int mos7810_check(struct usb_serial *serial) > /* Send the 1-bit test pattern out to MCS7810 test pin */ > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0), > MCS_WRREQ, MCS_WR_RTYPE, > - (0x0300 | (((test_pattern >> i) & 0x0001) << 1)), > + ((((test_pattern >> i) & 0x0001) << 1) | 0x0300), > MODEM_CONTROL_REGISTER, NULL, 0, MOS_WDR_TIMEOUT); > > /* Read the test pattern back */ > @@ -2059,7 +2059,7 @@ static int mos7810_check(struct usb_serial *serial) > > /* Restore MCR setting */ > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0), MCS_WRREQ, > - MCS_WR_RTYPE, 0x0300 | mcr_data, MODEM_CONTROL_REGISTER, NULL, > + MCS_WR_RTYPE, mcr_data | 0x0300, MODEM_CONTROL_REGISTER, NULL, > 0, MOS_WDR_TIMEOUT); > > kfree(buf); I feel I'm missing something here, so I have to ask the stupid question: What could possibly be the benefit here? Is it faster? Safer? Easier to read? Bjørn -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html