On Tue, 2015-11-10 at 14:24 +0100, Takashi Iwai wrote: > On Tue, 10 Nov 2015 14:15:44 +0100, > Oliver Neukum wrote: > > > > The documentation wrongly implied that it is a core parameter. > > That is not true. If usbcore is compiled as a module, a module > > parameter needs a prefix. > > The code drivers/usb/core/usb.c has the following: > > /* To disable USB, kernel command line is 'nousb' not 'usbcore.nousb' */ > #ifdef MODULE > module_param(nousb, bool, 0444); > #else > core_param(nousb, nousb, bool, 0444); > #endif > > ... which is quite confusing. > > This change was introduced by commit 785895ff1fed > USB: Don't use __module_param_call; use core_param. > > IMO, the current setup is a bad mixture to try keeping some > compatibility while breaking others. We should either keep "nousb" > always working or unify as a module option. Yes, I was premature. USB, however, is not a central feature, it is IO, so IMHO "usbcore.nousb" is the only correct option. I will prepare a set of changes to change that. Regards Oliver -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html