On Mon, Sep 21, 2015 at 05:01:05PM +0200, Peter Senna Tschudin wrote: > This patch fix coding style issues reported by checkpatch that do not > change semantics of the code. > > Signed-off-by: Peter Senna Tschudin <peter.senna@xxxxxxxxx> > --- > drivers/usb/host/fotg210-hcd.c | 1248 +++++++++++++++++----------------------- > drivers/usb/host/fotg210.h | 36 +- > 2 files changed, 558 insertions(+), 726 deletions(-) > > diff --git a/drivers/usb/host/fotg210-hcd.c b/drivers/usb/host/fotg210-hcd.c > index 000ed80..48eac34 100644 > --- a/drivers/usb/host/fotg210-hcd.c > +++ b/drivers/usb/host/fotg210-hcd.c > @@ -50,32 +50,30 @@ > #include <asm/irq.h> > #include <asm/unaligned.h> > > -/*-------------------------------------------------------------------------*/ > #define DRIVER_AUTHOR "Yuan-Hsin Chen" > #define DRIVER_DESC "FOTG210 Host Controller (EHCI) Driver" > - > -static const char hcd_name[] = "fotg210_hcd"; > +static const char hcd_name[] = "fotg210_hcd"; > > #undef FOTG210_URB_TRACE > - > #define FOTG210_STATS > > /* magic numbers that can affect system performance */ > -#define FOTG210_TUNE_CERR 3 /* 0-3 qtd retries; 0 == don't stop */ > -#define FOTG210_TUNE_RL_HS 4 /* nak throttle; see 4.9 */ > -#define FOTG210_TUNE_RL_TT 0 > -#define FOTG210_TUNE_MULT_HS 1 /* 1-3 transactions/uframe; 4.10.3 */ > -#define FOTG210_TUNE_MULT_TT 1 > +#define FOTG210_TUNE_CERR 3 /* 0-3 qtd retries; 0 == don't stop */ > +#define FOTG210_TUNE_RL_HS 4 /* nak throttle; see 4.9 */ > +#define FOTG210_TUNE_RL_TT 0 > +#define FOTG210_TUNE_MULT_HS 1 /* 1-3 transactions/uframe; 4.10.3 */ > +#define FOTG210_TUNE_MULT_TT 1 > + > /* > - * Some drivers think it's safe to schedule isochronous transfers more than > - * 256 ms into the future (partly as a result of an old bug in the scheduling > + * Some drivers think it's safe to schedule isochronous transfers more than 256 > + * ms into the future (partly as a result of an old bug in the scheduling > * code). In an attempt to avoid trouble, we will use a minimum scheduling > * length of 512 frames instead of 256. > */ > -#define FOTG210_TUNE_FLS 1 /* (medium) 512-frame schedule */ > +#define FOTG210_TUNE_FLS 1 /* (medium) 512-frame schedule */ > > /* Initial IRQ latency: faster than hw default */ > -static int log2_irq_thresh; /* 0 to 6 */ > +static int log2_irq_thresh; /* 0 to 6 */ > module_param(log2_irq_thresh, int, S_IRUGO); > MODULE_PARM_DESC(log2_irq_thresh, "log2 IRQ latency, 1-64 microframes"); > > @@ -89,66 +87,57 @@ static unsigned int hird; > module_param(hird, int, S_IRUGO); > MODULE_PARM_DESC(hird, "host initiated resume duration, +1 for each 75us"); > > -#define INTR_MASK (STS_IAA | STS_FATAL | STS_PCD | STS_ERR | STS_INT) > +#define INTR_MASK (STS_IAA | STS_FATAL | STS_PCD | STS_ERR | STS_INT) > > #include "fotg210.h" > > -/*-------------------------------------------------------------------------*/ > - > #define fotg210_dbg(fotg210, fmt, args...) \ > - dev_dbg(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args) > + dev_dbg(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args) > #define fotg210_err(fotg210, fmt, args...) \ > - dev_err(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args) > + dev_err(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args) > #define fotg210_info(fotg210, fmt, args...) \ > - dev_info(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args) > + dev_info(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args) > #define fotg210_warn(fotg210, fmt, args...) \ > - dev_warn(fotg210_to_hcd(fotg210)->self.controller , fmt , ## args) > + dev_warn(fotg210_to_hcd(fotg210)->self.controller, fmt, ## args) > > -/* check the values in the HCSPARAMS register > - * (host controller _Structural_ parameters) > - * see EHCI spec, Table 2-4 for each value > +/* check the values in the HCSPARAMS register (host controller _Structural_ if you're fixing coding style issues, you might as well go ahead and fix this comment style too: /* * check the values .... -- balbi
Attachment:
signature.asc
Description: PGP signature