The patch adding support to the generic PHY framework introduced a 'gen_phy' member in the HCD structure. Rename it to 'phy' to have a consistent USB framework. Signed-off-by: Antoine Tenart <antoine.tenart@xxxxxxxxxxxxxxxxxx> Acked-by: Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> --- drivers/usb/core/hcd.c | 22 +++++++++++----------- include/linux/usb/hcd.h | 4 +++- 2 files changed, 14 insertions(+), 12 deletions(-) diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c index 86fdce55ae16..6619239baf6d 100644 --- a/drivers/usb/core/hcd.c +++ b/drivers/usb/core/hcd.c @@ -2665,7 +2665,7 @@ int usb_add_hcd(struct usb_hcd *hcd, phy_put(phy); goto err_phy; } - hcd->gen_phy = phy; + hcd->phy = phy; } } @@ -2812,11 +2812,11 @@ err_allocate_root_hub: err_register_bus: hcd_buffer_destroy(hcd); err_create_buf: - if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->gen_phy) { - phy_power_off(hcd->gen_phy); - phy_exit(hcd->gen_phy); - phy_put(hcd->gen_phy); - hcd->gen_phy = NULL; + if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) { + phy_power_off(hcd->phy); + phy_exit(hcd->phy); + phy_put(hcd->phy); + hcd->phy = NULL; } err_phy: if (hcd->remove_phy && hcd->usb_phy) { @@ -2896,11 +2896,11 @@ void usb_remove_hcd(struct usb_hcd *hcd) usb_deregister_bus(&hcd->self); hcd_buffer_destroy(hcd); - if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->gen_phy) { - phy_power_off(hcd->gen_phy); - phy_exit(hcd->gen_phy); - phy_put(hcd->gen_phy); - hcd->gen_phy = NULL; + if (IS_ENABLED(CONFIG_GENERIC_PHY) && hcd->phy) { + phy_power_off(hcd->phy); + phy_exit(hcd->phy); + phy_put(hcd->phy); + hcd->phy = NULL; } if (hcd->remove_phy && hcd->usb_phy) { usb_phy_shutdown(hcd->usb_phy); diff --git a/include/linux/usb/hcd.h b/include/linux/usb/hcd.h index 604d2e6e0c1c..19b3fbd1f9e1 100644 --- a/include/linux/usb/hcd.h +++ b/include/linux/usb/hcd.h @@ -105,9 +105,11 @@ struct usb_hcd { /* * OTG and some Host controllers need software interaction with phys; * other external phys should be software-transparent + * + * Keep the usb_phy for compatibility reasons, for now */ struct usb_phy *usb_phy; - struct phy *gen_phy; + struct phy *phy; /* Flags that need to be manipulated atomically because they can * change while the host controller is running. Always use -- 1.9.1 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html