On Thu, 21 Aug 2014, Johan Hovold wrote: > > It's not really super-nice, but if no other way around it has been found > > to be possible in USB core, I am willing to take this. > > Agreed, it's not that nice, but I'm not aware of any other way to > prevent the device firmware from disconnecting. > > Autosuspend still seems to work, so it would not cause much overhead > for people not actually using the touchscreen (as long as autosuspend > is enabled) either. Okay, good. Will be waiting for your polished patch for this. [ ... snip ... ] > > > diff --git a/include/linux/hid.h b/include/linux/hid.h > > > index 77632cf..13f81ae 100644 > > > --- a/include/linux/hid.h > > > +++ b/include/linux/hid.h > > > @@ -286,6 +286,7 @@ struct hid_item { > > > #define HID_QUIRK_HIDINPUT_FORCE 0x00000080 > > > #define HID_QUIRK_NO_EMPTY_INPUT 0x00000100 > > > #define HID_QUIRK_NO_INIT_INPUT_REPORTS 0x00000200 > > > +#define HID_QUIRK_IN 0x00000400 > > > > 0x00000400 has been removed before dynamic quirks started to be possible, > > so there is no potential clash, that's fine. > > > > I'd just propose some more descriptive name for the quirk ... how about > > something like HID_QUIRK_EARLY_INTERRUPT? > > Yeah, IN was just a working name. How about HID_QUIRK_ALWAYS_POLL or > similar as it is not just about disconnect before the device is opened, > but also if there's an event after the device has been closed (e.g. > stopping X)? HID_QUIRK_ALWAYS_POLL sounds good. Thanks, -- Jiri Kosina SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html