switch over to endpoint feature flags so we can drop naming conventions. Signed-off-by: Felipe Balbi <balbi@xxxxxx> --- drivers/usb/chipidea/udc.c | 7 +++++++ 1 file changed, 7 insertions(+) diff --git a/drivers/usb/chipidea/udc.c b/drivers/usb/chipidea/udc.c index 80de2f8..e80dc82 100644 --- a/drivers/usb/chipidea/udc.c +++ b/drivers/usb/chipidea/udc.c @@ -1576,6 +1576,13 @@ static int init_eps(struct ci_hdrc *ci) hwep->ep.name = hwep->name; hwep->ep.ops = &usb_ep_ops; + + hwep->ep.has_bulk = true; + hwep->ep.has_interrupt = true; + hwep->ep.has_isochronous = true; + hwep->ep.has_dir_in = (j == TX); + hwep->ep.has_dir_out = (j == RX); + /* * for ep0: maxP defined in desc, for other * eps, maxP is set by epautoconfig() called -- 1.9.0 -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html