[PATCH 2/4] usb: renesas: switch over to endpoint feature flags

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



switch over to endpoint feature flags so we can
drop naming conventions.

Signed-off-by: Felipe Balbi <balbi@xxxxxx>
---
 drivers/usb/renesas_usbhs/mod_gadget.c | 11 +++++++++++
 1 file changed, 11 insertions(+)

diff --git a/drivers/usb/renesas_usbhs/mod_gadget.c b/drivers/usb/renesas_usbhs/mod_gadget.c
index 458f376..e798d7a 100644
--- a/drivers/usb/renesas_usbhs/mod_gadget.c
+++ b/drivers/usb/renesas_usbhs/mod_gadget.c
@@ -982,15 +982,26 @@ int usbhs_mod_gadget_probe(struct usbhs_priv *priv)
 
 		uep->ep.name		= uep->ep_name;
 		uep->ep.ops		= &usbhsg_ep_ops;
+
 		INIT_LIST_HEAD(&uep->ep.ep_list);
 
 		/* init DCP */
 		if (usbhsg_is_dcp(uep)) {
+			uep->ep.has_dir_in	= true;
+			uep->ep.has_dir_out	= true;
+			uep->ep.has_control	= true;
+
 			gpriv->gadget.ep0 = &uep->ep;
 			usb_ep_set_maxpacket_limit(&uep->ep, 64);
 		}
 		/* init normal pipe */
 		else {
+			uep->ep.has_dir_in	= true;
+			uep->ep.has_dir_out	= true;
+			uep->ep.has_bulk	= true;
+			uep->ep.has_interrupt	= true;
+			uep->ep.has_isochronous	= true;
+
 			usb_ep_set_maxpacket_limit(&uep->ep, 512);
 			list_add_tail(&uep->ep.ep_list, &gpriv->gadget.ep_list);
 		}
-- 
1.9.0

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux