On Wed, Dec 6, 2017 at 5:33 PM, Amir Goldstein <amir73il@xxxxxxxxx> wrote: > On Wed, Dec 6, 2017 at 5:03 PM, Miklos Szeredi <miklos@xxxxxxxxxx> wrote: >> --- a/fs/overlayfs/ovl_entry.h >> +++ b/fs/overlayfs/ovl_entry.h >> @@ -14,6 +14,8 @@ struct ovl_config { >> char *workdir; >> bool default_permissions; >> bool redirect_dir; >> + bool redirect_follow; > > IMO the configuration modes would be better describes by: > > enum ovl_redirect { > OVL_REDIRECT_OFF, > OVL_REDIRECT_FOLLOW, > OVL_REDIRECT_ON, > } > > Making the combination (!redirect_follow && redirect_dir) impossible > > instead of testing ofs->config.redirect_follow, can test > ofs->config.redirect >= OVL_REDIRECT_FOLLOW This is less readable, IMO. While it doesn't make any sense to create without follow, these two are in fact two separate functions, and having two bools for them is fine. The cost is one more line while parsing, which enforces sanity for setting these flags. Other comments fixed. Thanks for the review. Thanks, Miklos -- To unsubscribe from this list: send the line "unsubscribe linux-unionfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html