On 7/3/22 19:30, Daniel Lezcano wrote:
In order to use thermal trips defined in the thermal structure, rename the 'trips' field to 'ntrips' to have the 'trips' field containing the thermal trip points. Cc: Alexandre Bailon <abailon@xxxxxxxxxxxx> Cc: Kevin Hilman <khilman@xxxxxxxxxxxx> Cc; Eduardo Valentin <eduval@xxxxxxxxxx> Signed-off-by: Daniel Lezcano <daniel.lezcano@xxxxxxxxxx> --- drivers/thermal/gov_fair_share.c | 6 +++--- drivers/thermal/gov_power_allocator.c | 4 ++-- drivers/thermal/tegra/tegra30-tsensor.c | 2 +- drivers/thermal/thermal_core.c | 20 ++++++++++---------- drivers/thermal/thermal_helpers.c | 4 ++-- drivers/thermal/thermal_netlink.c | 2 +- drivers/thermal/thermal_sysfs.c | 22 +++++++++++----------- include/linux/thermal.h | 2 +- 8 files changed, 31 insertions(+), 31 deletions(-)
[snip]
diff --git a/include/linux/thermal.h b/include/linux/thermal.h index 6289b0bb1c97..3a57878a2a6c 100644 --- a/include/linux/thermal.h +++ b/include/linux/thermal.h
Missing updated ne name in comment here: * @trips: number of trip points the thermal zone supports
@@ -165,7 +165,7 @@ struct thermal_zone_device { struct thermal_attr *trip_hyst_attrs; enum thermal_device_mode mode; void *devdata; - int trips; + int ntrips; unsigned long trips_disabled; /* bitmap for disabled trips */ unsigned long passive_delay_jiffies; unsigned long polling_delay_jiffies;
Maybe this is only my bias, but this new name 'ntrips' looks like negation in electronics. We have examples like: num_cpus, num_pins, num_leds, num_groups, num_locks, num_buffers, num_phys, etc... Could we have 'num_trips' and follow to this convention here as well?