On Fri, Feb 15, 2013 at 06:36:54PM -0500, Rhyland Klein wrote: > This property is meant to be used in device nodes which represent > power_supply devices that wish to provide a list of supplies to > which they provide power. A common case is a AC Charger with > the batteries it powers. > > Signed-off-by: Rhyland Klein <rklein@xxxxxxxxxx> > --- > .../bindings/power_supply/power_supply.txt | 17 +++++++++++++++++ > 1 file changed, 17 insertions(+) > create mode 100644 Documentation/devicetree/bindings/power_supply/power_supply.txt > > diff --git a/Documentation/devicetree/bindings/power_supply/power_supply.txt b/Documentation/devicetree/bindings/power_supply/power_supply.txt > new file mode 100644 > index 0000000..1c58d4ff > --- /dev/null > +++ b/Documentation/devicetree/bindings/power_supply/power_supply.txt > @@ -0,0 +1,17 @@ > +Power Supply Core Support > + > +Optional Properties: > + - power-supply,supplied-nodes : This property is added to a supply > + in order to specify the list of supplicant devices directly by their > + phandles. "supplied nodes" sounds confusing (doesn't reflect direction), IMO. I'd rather call it power-supply,supplied-to = <&some_battery>; But... I'm recalling there was a similar discussion not that long ago, and Arnd came up with the idea that supplied-to is not fully in spirit of DT, and proposed his view of proper bindings. Please find the discussion here: http://lkml.org/lkml/2012/9/14/104 Thanks, Anton > + > +Example: > + > + charger@e { > + compatible = "some,charger"; > + ... > + > + power-supply,supplied-nodes = <&some_battery>, > + <&another_battery>; > + ... > + }; > -- > 1.7.9.5 -- To unsubscribe from this list: send the line "unsubscribe linux-tegra" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html