On 8/28/24 22:45, Manisha Singh wrote:
Remove multiple assignments from a line CHECK: multiple assignments should be avoided + pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct intf_priv),
Hi Manisha, please remove the 4 upper lines of the description. They are not required.
Refactor the _init_intf_hdl() function to avoid multiple assignments in a single statement. This change improves code readability and adheres to kernel coding style guidelines. Signed-off-by: Manisha Singh <masingh.linux@xxxxxxxxx> --- Changes Since V1: Broke the patch into 2 different fixes drivers/staging/rtl8712/rtl871x_io.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_io.c b/drivers/staging/rtl8712/rtl871x_io.c index 6789a4c98564..6311ac15c581 100644 --- a/drivers/staging/rtl8712/rtl871x_io.c +++ b/drivers/staging/rtl8712/rtl871x_io.c @@ -48,10 +48,10 @@ static uint _init_intf_hdl(struct _adapter *padapter, set_intf_funs = &(r8712_usb_set_intf_funs); set_intf_ops = &r8712_usb_set_intf_ops; init_intf_priv = &r8712_usb_init_intf_priv; - pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct intf_priv), - GFP_ATOMIC); + pintf_priv = kmalloc(sizeof(struct intf_priv), GFP_ATOMIC); if (!pintf_priv) goto _init_intf_hdl_fail;
By pushing the below statement after the "if (!pintf_priv)" you change the logic. Is this really wanted? Why do you think it is better? I would avoid this and it would be a separate patch anyhow.
+ pintf_hdl->pintfpriv = pintf_priv;
Thanks for your support. Bye Philipp
pintf_hdl->adapter = (u8 *)padapter; set_intf_option(&pintf_hdl->intf_option); set_intf_funs(pintf_hdl);