On Wed, Oct 18, 2023 at 03:59:27PM +0300, Dorcas Litunya wrote: > On Wed, Oct 18, 2023 at 02:06:41PM +0200, Julia Lawall wrote: > > > > > > On Wed, 18 Oct 2023, Dorcas AnonoLitunya wrote: > > > > > Modifies the return type of program_mode_registers() > > > to void from int as the return value is being ignored in > > > all subsequent function calls. > > > > > > This improves code readability and maintainability. > > > > > > Suggested-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> > > > Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx> > > > --- > > > drivers/staging/sm750fb/ddk750_mode.c | 5 ++--- > > > 1 file changed, 2 insertions(+), 3 deletions(-) > > > > > > diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c > > > index 83ace6cc9583..e15039238232 100644 > > > --- a/drivers/staging/sm750fb/ddk750_mode.c > > > +++ b/drivers/staging/sm750fb/ddk750_mode.c > > > @@ -73,8 +73,8 @@ display_control_adjust_sm750le(struct mode_parameter *mode_param, > > > } > > > > > > /* only timing related registers will be programed */ > > > -static int program_mode_registers(struct mode_parameter *mode_param, > > > - struct pll_value *pll) > > > +static void program_mode_registers(struct mode_parameter *mode_param, > > > + struct pll_value *pll) > > > { > > > int ret = 0; > > > int cnt = 0; > > > @@ -202,7 +202,6 @@ static int program_mode_registers(struct mode_parameter *mode_param, > > > } else { > > > ret = -1; > > > > Is it still useful to have ret = -1? Maybe the ret variable is not useful > > at all any more, but one would have to check the parts of the function > > that aren't shown. > > > I agree Julia. I will remove the setting part for ret = -1 but keep the > ret variable just in case it is being used by parts of the function not > shown. No, don't do that, you will trip other static checkers if you do so. Remove it entirely as it is obviously not needed anymore. thanks, greg k-h