Modifies the return type of program_mode_registers() to void from int as the return value is being ignored in all subsequent function calls. This improves code readability and maintainability. Suggested-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> Signed-off-by: Dorcas AnonoLitunya <anonolitunya@xxxxxxxxx> --- drivers/staging/sm750fb/ddk750_mode.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c index 83ace6cc9583..e15039238232 100644 --- a/drivers/staging/sm750fb/ddk750_mode.c +++ b/drivers/staging/sm750fb/ddk750_mode.c @@ -73,8 +73,8 @@ display_control_adjust_sm750le(struct mode_parameter *mode_param, } /* only timing related registers will be programed */ -static int program_mode_registers(struct mode_parameter *mode_param, - struct pll_value *pll) +static void program_mode_registers(struct mode_parameter *mode_param, + struct pll_value *pll) { int ret = 0; int cnt = 0; @@ -202,7 +202,6 @@ static int program_mode_registers(struct mode_parameter *mode_param, } else { ret = -1; } - return ret; } int ddk750_set_mode_timing(struct mode_parameter *parm, enum clock_type clock) -- 2.42.0.345.gaab89be2eb