On Wed, Jul 12, 2023 at 04:35:13PM -0700, Tree Davies wrote: > Rename variable pBA to pba in order to Fix checkpatch > warning: Avoid CamelCase > > Signed-off-by: Tree Davies <tdavies@xxxxxxxxxxxxxxx> > --- > drivers/staging/rtl8192e/rtl819x_BAProc.c | 106 +++++++++++----------- > drivers/staging/rtl8192e/rtllib.h | 2 +- > 2 files changed, 54 insertions(+), 54 deletions(-) > > diff --git a/drivers/staging/rtl8192e/rtl819x_BAProc.c b/drivers/staging/rtl8192e/rtl819x_BAProc.c > index 6b5da38353ee..43ee1bd4a6ed 100644 > --- a/drivers/staging/rtl8192e/rtl819x_BAProc.c > +++ b/drivers/staging/rtl8192e/rtl819x_BAProc.c > @@ -10,17 +10,17 @@ > #include "rtllib.h" > #include "rtl819x_BA.h" > > -static void activate_ba_entry(struct ba_record *pBA, u16 Time) > +static void activate_ba_entry(struct ba_record *pba, u16 Time) Here the "p" stands for "pointer". This style of naming is not allowed in the Linux kernel. Just use "ba" as a name. This happens in a couple other patches as well so fix those too. regards, dan carpenter