Re: [PATCH 1/2] staging: vme_user: add space around operators

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Menna Mahmoud wrote:
> add a space before and after the operator, for readability.
> 
> Reported By checkpatch script:
> 
> CHECK: spaces preferred around that '+' (ctx:VxV)
> +		image->bus_resource.name = kmalloc(VMENAMSIZ+3, GFP_ATOMIC);
>  		                                            ^
> CHECK: spaces preferred around that '<<' (ctx:VxV)
> +	temp_ctl &= ~(3<<4);
>  	               ^
> CHECK: spaces preferred around that '>>' (ctx:VxV)
> +	cbar = (cbar & TSI148_CRCSR_CBAR_M)>>3;
>  	                                   ^
> CHECK: spaces preferred around that '<<' (ctx:VxV)
> +		iowrite32be(cbar<<3, bridge->base + TSI148_CBAR);

Similar comment to what Fabio made.

But I'll add some formatting comments.

It looks like you have submitted a 2 patch series which fixes all the
checkpatch errors in the vme_user driver?

Kudos for separating out the 2 patches for the 2 different types of
checkpatch errors!  And for submitting a series which fixes the entire
driver!

But you should also include a cover letter for your series.

How are you creating this series?  Are you using 'git format-patch'?
'b4'?  If not using 'b4' I strongly recommend it.[*]

Both of those tools can help with formatting a cover letter and b4 will
help keep track of multiple versions of the series as you fix things.

Ira

[*] https://git.kernel.org/pub/scm/utils/b4/b4.git




[Index of Archives]     [Linux Driver Development]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux