On Sun, Jul 10, 2022 at 02:04:18PM -0700, Binyi Han wrote: > Fix indentation issue to adhere to Linux kernel coding style, > Issue found by checkpatch. Change the long for loop into 3 lines. And > optimize by avoiding the multiplication. There is no possible way this optimization helps benchmarks. Better to focus on readability. > > Signed-off-by: Binyi Han <dantengknight@xxxxxxxxx> > --- > v2: > - Change the long for loop into 3 lines. > v3: > - Align page_entries in the for loop to open parenthesis. > - Optimize by avoiding the multiplication. > > drivers/staging/qlge/qlge_main.c | 20 ++++++++++++-------- > 1 file changed, 12 insertions(+), 8 deletions(-) > > diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_main.c > index 1a378330d775..4b166c66cfc5 100644 > --- a/drivers/staging/qlge/qlge_main.c > +++ b/drivers/staging/qlge/qlge_main.c > @@ -3007,10 +3007,12 @@ static int qlge_start_rx_ring(struct qlge_adapter *qdev, struct rx_ring *rx_ring > tmp = (u64)rx_ring->lbq.base_dma; > base_indirect_ptr = rx_ring->lbq.base_indirect; > > - for (page_entries = 0; page_entries < > - MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); page_entries++) > - base_indirect_ptr[page_entries] = > - cpu_to_le64(tmp + (page_entries * DB_PAGE_SIZE)); > + for (page_entries = 0; > + page_entries < MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); > + page_entries++) { > + base_indirect_ptr[page_entries] = cpu_to_le64(tmp); > + tmp += DB_PAGE_SIZE; I've previously said that using "int i;" is clearer here. You would kind of expect "page_entries" to be the number of entries, so it's kind of misleading. In other words, it's not just harmless wordiness and needless exposition, it's actively bad. I would probably just put it on one line: for (i = 0; i MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); i++) base_indirect_ptr[i] = cpu_to_le64(tmp + (i * DB_PAGE_SIZE)); But if you want to break it up you could do: for (i = 0; i MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); i++) base_indirect_ptr[i] = cpu_to_le64(tmp + (i * DB_PAGE_SIZE)); "tmp" is kind of a bad name. Also "base_indirect_ptr" would be better as "base_indirect". regards, dan carpenter