On Tue, 2021-08-17 at 20:49 +0200, Greg KH wrote: > On Tue, Aug 17, 2021 at 11:36:09AM -0700, Joe Perches wrote: > > On Tue, 2021-08-17 at 19:57 +0200, Greg KH wrote: > > > On Mon, Aug 16, 2021 at 09:31:25PM +0200, Michael Straube wrote: > > > > Refactor functions rtw_is_cckrates_included() and > > > > rtw_is_cckratesonly_included(). Add new helper function rtw_is_cckrate() > > > > that allows to make the code more compact. Improves readability and > > > > slightly reduces object file size. Change the return type to bool to > > > > reflect that the functions return boolean values. > > [] > > > > diff --git a/drivers/staging/r8188eu/core/rtw_ieee80211.c b/drivers/staging/r8188eu/core/rtw_ieee80211.c > > [] > > > > +bool rtw_is_cckratesonly_included(u8 *rate) > > > > { > > > > - u32 i = 0; > > > > + u8 r; > > > > > > > > > > > > - while (rate[i] != 0) { > > > > - if ((((rate[i]) & 0x7f) != 2) && (((rate[i]) & 0x7f) != 4) && > > > > - (((rate[i]) & 0x7f) != 11) && (((rate[i]) & 0x7f) != 22)) > > > > + while ((r = *rate++)) { > > > > > > Ick, no. > > > > > > While it might be fun to play with pointers like this, trying to > > > determine the precidence issues involved with reading from, and then > > > incrementing the pointer like this is crazy. > > > > > > The original was obvious as to how it was walking through the array. > > > > It's sad to believe *ptr++ is not obvious to you as it's very commonly > > used in the kernel sources (over 10,000 instances). > > There's lots of sad things in life :( Your difficulty reading very standard c is relatively low on my list. Still, it's you not this particular patch to the realtek staging code. What's really poor about this code is using a 0 terminated list rather than passing the array size. But then again, almost all of the realtek code in staging is really poor. cheers, Joe