This is a small series that improves error handling in the probe path of the Rockchip SPI drivers, by using dev_err_probe() properly in multiple places. It also removes one unnecessary check of a function return value, and performs a bunch of small, rather trivial code cleanups, to make the code neater and a bit easier to read. Dragan Simic (5): spi: rockchip: Perform trivial code cleanups spi: rockchip-sfc: Perform trivial code cleanups spi: rockchip: Don't check for failed get_fifo_len() spi: rockchip: Use dev_err_probe() in the probe path spi: rockchip-sfc: Use dev_err_probe() in the probe path drivers/spi/spi-rockchip-sfc.c | 21 +++++-------- drivers/spi/spi-rockchip.c | 57 ++++++++++++++-------------------- 2 files changed, 32 insertions(+), 46 deletions(-)