Hi Greg, Thanks for your review. On Thu, Mar 23, 2023 at 07:05:22PM +0100, Greg Kroah-Hartman wrote: > On Fri, Mar 24, 2023 at 01:21:08AM +0800, Ye Xiang wrote: > > +config USB_LJCA > > + tristate "Intel La Jolla Cove Adapter support" > > + select AUXILIARY_BUS > > + depends on USB > > + help > > + This adds support for Intel La Jolla Cove USB-I2C/SPI/GPIO > > + Master Adapter (LJCA). Additional drivers such as I2C_LJCA, > > + GPIO_LJCA and SPI_LJCA must be enabled in order to use the > > + functionality of the device. > > + > > + This driver can also be built as a module. If so, the module > > + will be called ljca. > > That's a very generic name for a USB driver, why not "usb_ljca"? Thanks for the suggestion. Will adopt it on next version. > > > +struct ljca_dev { > > + struct usb_device *udev; > > You didn't remove this like you said you would :( Sorry. I just stopped using it, but I forgot to delete it in struct ljca_dev. The udev field is unused in this driver now. I will definitely delete it on next version. -- Thanks Ye Xiang