On Thu, 2023-03-02 at 09:48 +0530, Krishna Yarlagadda wrote: > +int tpm_tis_spi_transfer(struct tpm_tis_data *data, u32 addr, u16 > len, > + u8 *in, const u8 *out) > +{ > + struct tpm_tis_spi_phy *phy = to_tpm_tis_spi_phy(data); > + struct spi_controller *ctlr = phy->spi_device->controller; > + > + /* > + * TPM flow control over SPI requires full duplex support. > + * Send entire message to a half duplex controller to handle > + * wait polling in controller. > + * Set TPM HW flow control flag.. > + */ > + if (ctlr->flags & SPI_CONTROLLER_HALF_DUPLEX) > + return tpm_tis_spi_hw_flow_transfer(data, addr, len, > in, > + out); > + else > + return tpm_tis_spi_sw_flow_transfer(data, addr, len, > in, > + out); > +} > + Based on the condition, better names would be 1. tpm_tis_spi_transfer_half() 2. tpm_tis_spi_transfer_full() BR, Jarkko