> On 01.12.2015, at 22:04, Mark Brown <broonie@xxxxxxxxxx> wrote: > >> On Mon, Nov 30, 2015 at 01:04:52PM +0000, kernel@xxxxxxxxxxxxxxxx wrote: >> >> +static struct spi_res *__spi_res_alloc(struct spi_device *spi, >> + spi_res_release_t release, >> + size_t size, >> + gfp_t gfp) > > This has exactly one (tiny) user. Why is it a separate function? Readability, mimicking devres code and the option of adding object caching/reuse here later... There is a much higher likelihood that spi_resources will be allocated and then freed several times per second, so this can save cpu cycles and avoid locks... > >> + sres = kzalloc(tot_size, gfp); >> + if (unlikely(!sres)) >> + return NULL; > > Don't use likely() or unlikely() annotations unless the code is *really* > performance critical, just let the optimiser get on with things. The > annotations most likely cost more time in reading the code than they'll > ever save. Same code structure was used with devres, so I copied it. -- To unsubscribe from this list: send the line "unsubscribe linux-spi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html