On Tue, 2015-02-24 at 13:32 +0200, Andy Shevchenko wrote: > This patch removes a lot of duplicate code since SPI core provides a nice > message handling. > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > -void dw_spi_xfer_done(struct dw_spi *dws) > -{ > - /* Update total byte transferred return count actual bytes read */ > - dws->cur_msg->actual_length += dws->len; > - > - /* Move to next transfer */ > - dws->cur_msg->state = next_transfer(dws); > - > - /* Handle end of message */ > - if (dws->cur_msg->state == DONE_STATE) { > - dws->cur_msg->status = 0; > - giveback(dws); > - } else > - tasklet_schedule(&dws->pump_transfers); > -} > -EXPORT_SYMBOL_GPL(dw_spi_xfer_done); This one should be removed from spi-dw.h as well. -- Andy Shevchenko <andriy.shevchenko@xxxxxxxxx> Intel Finland Oy -- To unsubscribe from this list: send the line "unsubscribe linux-spi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html