On Thu, Aug 17, 2017 at 9:19 AM, Christopher Li <sparse@xxxxxxxxxxx> wrote: >> >> +static inline int is_simple_type(struct symbol *type) > ... >> + case SYM_STRUCT: >> + case SYM_UNION: >> + return type->bit_size <= long_ctype.bit_size; > > I think the function name should be some thing along the > line of "type fits register" or is_registerable_type. > > union and struct are composite types. It is a bit > confusing calling them simple, if some one just looking > at the code without look at the commit message. I agree it's confusing, and yes I would like a better name. OTOH 'registrable' is not exactly the conveyed meaning. 'register' is a concept that pertains to the backend, that is machine specific, a pseudo may need several registers and a register can hold several pseudos, ... Here what we really want to select is something along: 'it's interesting to see it as a flow of value' vs. 'it's better to see it as a change in state'. And yes, very often that just correspond to registers. Note: it's not even 'what can be put in a pseudo(-register)' were selecting here. It's OK to have pseudos for 'non-simple' values, They will just be transient and we won't be interested in their 'flow'. -- Luc -- To unsubscribe from this list: send the line "unsubscribe linux-sparse" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html