On Fri, 14 Jun 2024, Udit Kumar wrote: > As per Errata i2310[0], Erroneous timeout can be triggered, > if this Erroneous interrupt is not cleared then it may leads > to strom of interrupts, therefore apply Errata i2310 solution. > > [0] https://www.ti.com/lit/pdf/sprz536 page 23 > > Signed-off-by: Udit Kumar <u-kumar1@xxxxxx> > --- > drivers/tty/serial/8250/8250_omap.c | 25 ++++++++++++++++++++----- > 1 file changed, 20 insertions(+), 5 deletions(-) > > diff --git a/drivers/tty/serial/8250/8250_omap.c b/drivers/tty/serial/8250/8250_omap.c > index 170639d12b2a..38eb639f78d3 100644 > --- a/drivers/tty/serial/8250/8250_omap.c > +++ b/drivers/tty/serial/8250/8250_omap.c > @@ -115,6 +115,10 @@ > /* RX FIFO occupancy indicator */ > #define UART_OMAP_RX_LVL 0x19 > > +/* Timeout Low and High */ > +#define UART_OMAP_TO_L 0x26 > +#define UART_OMAP_TO_H 0x27 > + > /* > * Copy of the genpd flags for the console. > * Only used if console suspend is disabled > @@ -663,13 +667,24 @@ static irqreturn_t omap8250_irq(int irq, void *dev_id) > > /* > * On K3 SoCs, it is observed that RX TIMEOUT is signalled after > - * FIFO has been drained, in which case a dummy read of RX FIFO > - * is required to clear RX TIMEOUT condition. > + * FIFO has been drained or erroneously. > + * So apply solution of Errata i2310 as mentioned in > + * https://www.ti.com/lit/pdf/sprz536 > */ > if (priv->habit & UART_RX_TIMEOUT_QUIRK && > - (iir & UART_IIR_RX_TIMEOUT) == UART_IIR_RX_TIMEOUT && > - serial_port_in(port, UART_OMAP_RX_LVL) == 0) { > - serial_port_in(port, UART_RX); > + (iir & UART_IIR_RX_TIMEOUT) == UART_IIR_RX_TIMEOUT) { > + unsigned char efr2, timeout_h, timeout_l; > + > + efr2 = serial_in(up, UART_OMAP_EFR2); > + timeout_h = serial_in(up, UART_OMAP_TO_H); > + timeout_l = serial_in(up, UART_OMAP_TO_L); > + serial_out(up, UART_OMAP_TO_H, 0xFF); > + serial_out(up, UART_OMAP_TO_L, 0xFF); > + serial_out(up, UART_OMAP_EFR2, 0x1); Eh, this doesn't match the workaround in the errata??? Also, don't use literals but name the bits with defines (for the correct bit there's probably a pre-existing define but it's not named as good as it could be, I'd say it should be named as UART_OMAP_EFR2_TIMEOUT_PERIODIC). > + serial_in(up, UART_IIR); > + serial_out(up, UART_OMAP_EFR2, efr2); > + serial_out(up, UART_OMAP_TO_H, timeout_h); > + serial_out(up, UART_OMAP_TO_L, timeout_l); -- i.