A few issues have been found with device naming for the serial core controller port device. These issues currently mostly affect the output for /sys/bus/serial-base/devices, but need to be also fixed to avoid port addressing issues later on. Changes since v4: - Make the sysfs device names nicer with DEVNAME:0.0 naming, the "ctrl" and "port" prefixes are not needed with the controller id in the name - Fix Andy's Reviewed-by as noted by Andy - Generate patches with --patience to make the last patch more readable Changes since v3: - Drop unnecessary else on the return path in serial_base_device_init() as noted by Andy - Add Andy's Reviewed-by - Update patch description for port_id instead of port port_id for the first patch Changes since v2: - Fix my email script as it had started to drop linux-serial as noted by Greg - Explain why we're changing ctrl_id as requested by Greg Changes since v1: - Port id cannot be negative as noted by Jiri - Controller id cannot be negative as noted by Andy - Port name is missing the controller instance as noted by Andy Tony Lindgren (3): serial: core: Controller id cannot be negative serial: core: Fix serial core port id to not use port->line serial: core: Fix serial core controller port name to show controller id drivers/tty/serial/8250/8250_core.c | 2 ++ drivers/tty/serial/serial_base_bus.c | 32 +++++++++++++++++----------- include/linux/serial_core.h | 3 ++- 3 files changed, 24 insertions(+), 13 deletions(-) -- 2.41.0