[PATCH 0/8] serial: Core cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Serial core cleanups.

Ilpo Järvinen (8):
  serial: Use ARRAY_SIZE() with iso7816 reserved array
  serial: Use B0 instead of implicit zero assumption
  serial: Remove extern from func prototypes in headers
  serial: Move uart_change_speed() earlier
  serial: Rename uart_change_speed() to uart_change_line_settings()
  serial: Make hw_stopped bool
  serial: Rename hw_stopped to old_hw_stopped & improve logic
  serial: Remove uart_wait_until_sent() forward declaration

 drivers/tty/serial/serial_core.c | 113 +++++++++++++++----------------
 include/linux/serial_8250.h      |  41 +++++------
 include/linux/serial_core.h      |  15 ++--
 3 files changed, 80 insertions(+), 89 deletions(-)

-- 
2.30.2




[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux PPP]     [Linux FS]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Linmodem]     [Device Mapper]     [Linux Kernel for ARM]

  Powered by Linux