On Fri, Jan 27, 2023 at 05:40:36PM +0100, Gatien Chevallier wrote: > feature-domains is an optional property that allows a peripheral to > refer to one or more feature domain controller(s). > > Description of this property is added to all peripheral binding files of > the peripheral under the STM32 System Bus. It allows an accurate > representation of the hardware, where various peripherals are connected > to this firewall bus. The firewall can then check the peripheral accesses > before allowing it to probe. > > Signed-off-by: Gatien Chevallier <gatien.chevallier@xxxxxxxxxxx> > --- > > Patch not present in V1 and V2. > > Documentation/devicetree/bindings/crypto/st,stm32-hash.yaml | 5 +++++ > Documentation/devicetree/bindings/dma/st,stm32-dma.yaml | 5 +++++ > Documentation/devicetree/bindings/dma/st,stm32-dmamux.yaml | 5 +++++ > Documentation/devicetree/bindings/i2c/st,stm32-i2c.yaml | 5 +++++ > Documentation/devicetree/bindings/iio/adc/st,stm32-adc.yaml | 5 +++++ > .../devicetree/bindings/iio/adc/st,stm32-dfsdm-adc.yaml | 5 +++++ > Documentation/devicetree/bindings/iio/dac/st,stm32-dac.yaml | 5 +++++ > Documentation/devicetree/bindings/media/st,stm32-cec.yaml | 5 +++++ > Documentation/devicetree/bindings/media/st,stm32-dcmi.yaml | 5 +++++ > .../bindings/memory-controllers/st,stm32-fmc2-ebi.yaml | 5 +++++ > Documentation/devicetree/bindings/mfd/st,stm32-lptimer.yaml | 5 +++++ > Documentation/devicetree/bindings/mfd/st,stm32-timers.yaml | 6 ++++++ > Documentation/devicetree/bindings/mmc/arm,pl18x.yaml | 5 +++++ > Documentation/devicetree/bindings/net/stm32-dwmac.yaml | 5 +++++ > .../devicetree/bindings/phy/phy-stm32-usbphyc.yaml | 5 +++++ > .../devicetree/bindings/regulator/st,stm32-vrefbuf.yaml | 5 +++++ > Documentation/devicetree/bindings/rng/st,stm32-rng.yaml | 5 +++++ > Documentation/devicetree/bindings/serial/st,stm32-uart.yaml | 5 +++++ > Documentation/devicetree/bindings/sound/st,stm32-i2s.yaml | 5 +++++ > Documentation/devicetree/bindings/sound/st,stm32-sai.yaml | 5 +++++ > .../devicetree/bindings/sound/st,stm32-spdifrx.yaml | 5 +++++ > Documentation/devicetree/bindings/spi/st,stm32-qspi.yaml | 5 +++++ > Documentation/devicetree/bindings/spi/st,stm32-spi.yaml | 5 +++++ > Documentation/devicetree/bindings/usb/dwc2.yaml | 5 +++++ > 24 files changed, 121 insertions(+) > > diff --git a/Documentation/devicetree/bindings/crypto/st,stm32-hash.yaml b/Documentation/devicetree/bindings/crypto/st,stm32-hash.yaml > index 4ccb335e8063..cb2ad7d5fdb5 100644 > --- a/Documentation/devicetree/bindings/crypto/st,stm32-hash.yaml > +++ b/Documentation/devicetree/bindings/crypto/st,stm32-hash.yaml > @@ -41,6 +41,11 @@ properties: > maximum: 2 > default: 0 > > + feature-domains: > + $ref: /schemas/feature-controllers/feature-domain-controller.yaml#/properties/feature-domains Not how common properties work. Consumer properties should be in a schema with 'select: true' (the one you are referencing) and here you just need to define the entries. Like clocks, power-domains, etc. > + minItems: 1 > + maxItems: 3 Why is this variable and what is each entry? I still don't like the naming. Everything is a feature and a domain... It might be a bit easier to come up with a name with multiple users of this binding presented. I'm hesistant to define any new common binding with only 1 user as I've said multiple times on this binding. Rob