On Mon, Nov 07, 2022 at 12:14:58PM -0500, Gabriel Somlo wrote: > Make some cosmetic/stylistic (non-functional) improvements: > > 1. Use a DRV_NAME macro to avoid hard-coding "liteuart" in multiple > locations throughout the source file > > 2. Use bit numbers instead of magic constants for event flags > > 3. Remove stub uart_ops methods that are not called unconditionally > from serial_core; Document stubs that are required by serial_core > > 4. Don't set unused port->regshift and port->iobase fields gratuitously > during probe() > > 5. Improve coding style in liteuart_init() When you list different things you do in a single patch, that means you should break this up into individual patches. Please do that here, this should be at least 5 patches. > > Signed-off-by: Gabriel Somlo <gsomlo@xxxxxxxxx> > --- > drivers/tty/serial/liteuart.c | 38 +++++++++-------------------------- > 1 file changed, 10 insertions(+), 28 deletions(-) > > diff --git a/drivers/tty/serial/liteuart.c b/drivers/tty/serial/liteuart.c > index 4c0604325ee9..4b9cca249828 100644 > --- a/drivers/tty/serial/liteuart.c > +++ b/drivers/tty/serial/liteuart.c > @@ -18,6 +18,8 @@ > #include <linux/tty_flip.h> > #include <linux/xarray.h> > > +#define DRV_NAME "liteuart" Just use KBUILD_MODNAME please. thanks, greg k-h