On Tue, 7 Jun 2022, Jiri Slaby wrote: > The code uses constants for sizes of dictionary substructures on many > places. Define 3 macros and use them in the code, so that loop bounds, > local variables and the dictionary always match. (And the loop bounds > are obvious now too.) > > Signed-off-by: Jiri Slaby <jslaby@xxxxxxx> Reviewed-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx> > - for (k = 0; k < 64; k++) { > + for (k = 0; k < UNI_ROW_GLYPHS; k++) { > glyph = p2[k]; > if (glyph >= 0 && glyph < MAX_GLYPH > && q[glyph] < 32) Probably unrelated to this change but what's that < 32? It seems to appear twice related to the inverse mapping (and you didn't end up naming it). -- i.