On Fri, Apr 24, 2020 at 09:40:18AM +0900, Hyunki Koo wrote: > On Sat, April 21, 2020 at 08:36:00 AM +0900, Hyunki Koo wrote: > > > > Change in v8: > > - spit into 3 patch > > [1/3] create the new functions with no functional change to the code as- > > is. > > Replace rd_regb/wr_regb with rd_reg/wr_reg for general usage. > > [2/3] add the new binding reg-io-width in device tree > > [3/3] add the new funtinality of rd_reg / wr_reg and wr_reg_barrier > > to support 32-bit access for the TX/RX hold registers UTXH and URXH. > > > > Change in v7: > > - [1/2] correct build error on running 'make dt_binding_check' > > Documentation/devicetree/bindings/serial/samsung_uart.yaml: mapping > > values are not allowed in this context > > in "<unicode string>", line 36, column 13 > > Documentation/devicetree/bindings/Makefile:12: recipe for target > > 'Documentation/devicetree/bindings/serial/samsung_uart.example.dts' > > failed > > make[1]: *** > > [Documentation/devicetree/bindings/serial/samsung_uart.example.dts] > > Error 1 > > make[1]: *** Waiting for unfinished jobs.... > > Makefile:1262: recipe for target 'dt_binding_check' failed > > make: *** [dt_binding_check] Error 2 > > - [2/2] add commit message of reviewed by and tested by in commit > > message > > Reviewed-by: Krzysztof Kozlowski <krzk@xxxxxxxxxx> > > Tested on Odroid HC1 (Exynos5422): > > Tested-by: Krzysztof Kozlowski <krzk@xxxxxxxxxx> > > > > Change in v6: > > - [2/2] clean description of reg-io-width > > allOf is not needed. Just enum [1, 2] is enough. > > > > Changes in v5: > > - spit into 2 patch, newly added patch for dt-binding > > [1/2] newly added dt-binding and go as first patch in this series. > > [2/2] go as second patch in this series. > > > > Changes in v4: > > - correct variable types and change misleading function name > > > > Changes in v3: > > - line 2031: remove redundant init value for ourport->port.iotype > > > > Changes in v2: > > - line 954 : change rd_regl to rd_reg in for backward compatibility. > > - line 2031: Add init value for ourport->port.iotype to UPIO_MEM > > > > > > Hyunki Koo (3): > > serial: samsung: Replace rd_regb/wr_regb with rd_reg/wr_reg > > dt-bindings: serial: Add reg-io-width compatible > > tty: samsung_tty: 32-bit access for TX/RX hold registers > > > > .../devicetree/bindings/serial/samsung_uart.yaml | 8 +++ > > drivers/tty/serial/samsung_tty.c | 76 ++++++++++++++++++--- > > - > > 2 files changed, 72 insertions(+), 12 deletions(-) > > > > -- > > 2.15.0.rc1 > > Hi Greg KH > > Can I ask is this series patch are acceptable or not? > Do you think, I have to do any further action for this patch? > It's been 3 days, give us a chance please... Also, I need to wait for the dt patch to be reviewed first before I can take any of this, so that's up to the DT maintainers. thanks, greg k-h