On 2019-10-16 17:18, Philippe Schenker wrote: > Use UARTMODIR defines instead of UARTMODEM as it is a 32-bit function This reads a bit strange at first. Also it is helpful for later to state that this does not make a difference in practise, so how about: Use define from the 32-bit register description UARTMODIR_* instead of UARTMODEM_*. The value is the same, so there is no functional change. Otherwise looks good to me: Reviewed-by: Stefan Agner <stefan.agner@xxxxxxxxxxx> -- Stefan > > Signed-off-by: Philippe Schenker <philippe.schenker@xxxxxxxxxxx> > --- > > drivers/tty/serial/fsl_lpuart.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/tty/serial/fsl_lpuart.c b/drivers/tty/serial/fsl_lpuart.c > index f3271857621c..346b4a070ce9 100644 > --- a/drivers/tty/serial/fsl_lpuart.c > +++ b/drivers/tty/serial/fsl_lpuart.c > @@ -1879,10 +1879,10 @@ lpuart32_set_termios(struct uart_port *port, > struct ktermios *termios, > } > > if (termios->c_cflag & CRTSCTS) { > - modem |= UARTMODEM_RXRTSE | UARTMODEM_TXCTSE; > + modem |= (UARTMODIR_RXRTSE | UARTMODIR_TXCTSE); > } else { > termios->c_cflag &= ~CRTSCTS; > - modem &= ~(UARTMODEM_RXRTSE | UARTMODEM_TXCTSE); > + modem &= ~(UARTMODIR_RXRTSE | UARTMODIR_TXCTSE); > } > > if (termios->c_cflag & CSTOPB)