On Tue, 19 Apr 2022 15:57:43 -0700, Bart Van Assche wrote: > This patch series includes the following changes: > - Split the ufshcd.h header file into two header files - one file that > defines the interface with UFS drivers and another file with definitions > only used in the core. > - Multiple source code cleanup patches. > - A few patches with minor functional changes. > > [...] Applied to 5.19/scsi-queue, thanks! [01/28] scsi: ufs: Fix a spelling error in a source code comment https://git.kernel.org/mkp/scsi/c/2abe58002364 [02/28] scsi: ufs: Declare ufshcd_wait_for_register() static https://git.kernel.org/mkp/scsi/c/59a57bb79e10 [03/28] scsi: ufs: Remove superfluous boolean conversions https://git.kernel.org/mkp/scsi/c/51d1628fc457 [04/28] scsi: ufs: Simplify statements that return a boolean https://git.kernel.org/mkp/scsi/c/a858af9a9e01 [05/28] scsi: ufs: Remove ufshcd_lrb.sense_bufflen https://git.kernel.org/mkp/scsi/c/b639b59b44fd [06/28] scsi: ufs: Remove ufshcd_lrb.sense_buffer https://git.kernel.org/mkp/scsi/c/1de4378f6057 [07/28] scsi: ufs: Use get_unaligned_be16() instead of be16_to_cpup() https://git.kernel.org/mkp/scsi/c/9d3ab17e840c [08/28] scsi: ufs: Remove the UFS_FIX() and END_FIX() macros https://git.kernel.org/mkp/scsi/c/dd2cf44ff4ec [09/28] scsi: ufs: Rename struct ufs_dev_fix into ufs_dev_quirk https://git.kernel.org/mkp/scsi/c/25eff2f543b1 [10/28] scsi: ufs: Declare the quirks array const https://git.kernel.org/mkp/scsi/c/aead21f32ae7 [11/28] scsi: ufs: Invert the return value of ufshcd_is_hba_active() https://git.kernel.org/mkp/scsi/c/acbbfe484faa [12/28] scsi: ufs: Remove unused constants and code https://git.kernel.org/mkp/scsi/c/9474c64e83ca [13/28] scsi: ufs: Switch to aggregate initialization https://git.kernel.org/mkp/scsi/c/778d2b0ec6d1 [14/28] scsi: ufs: Make the config_scaling_param calls type safe https://git.kernel.org/mkp/scsi/c/c906e8328de8 [15/28] scsi: ufs: Remove the driver version https://git.kernel.org/mkp/scsi/c/b4ade33b0d16 [16/28] scsi: ufs: Rename sdev_ufs_device into ufs_device_wlun https://git.kernel.org/mkp/scsi/c/e2106584d011 [17/28] scsi: ufs: Use an SPDX license identifier in the Kconfig file https://git.kernel.org/mkp/scsi/c/2b10863f7163 [18/28] scsi: ufs: Remove paths from source code comments https://git.kernel.org/mkp/scsi/c/d0c1725b1e64 [19/28] scsi: ufs: Remove the TRUE and FALSE definitions https://git.kernel.org/mkp/scsi/c/21c2e3418d07 [20/28] scsi: ufs: Remove locking from around single register writes https://git.kernel.org/mkp/scsi/c/3fb20fcd93fe [21/28] scsi: ufs: Introduce ufshcd_clkgate_delay_set() https://git.kernel.org/mkp/scsi/c/ad8a647e7729 [22/28] scsi: ufs: qcom: Fix ufs_qcom_resume() https://git.kernel.org/mkp/scsi/c/bee40dc167da [23/28] scsi: ufs: Remove unnecessary ufshcd-crypto.h include directives https://git.kernel.org/mkp/scsi/c/c10d52d73ae0 [24/28] scsi: ufs: Fix kernel-doc syntax in ufshcd.h https://git.kernel.org/mkp/scsi/c/cff91daf52d3 [25/28] scsi: ufs: Minimize #include directives https://git.kernel.org/mkp/scsi/c/3f06f7800b80 [26/28] scsi: ufs: Split the ufshcd.h header file https://git.kernel.org/mkp/scsi/c/4bc26113c603 [27/28] scsi: ufs: Move the struct ufs_ref_clk definition https://git.kernel.org/mkp/scsi/c/743b09d8541e [28/28] scsi: ufs: Move the ufs_is_valid_unit_desc_lun() definition https://git.kernel.org/mkp/scsi/c/a8b032b5b3ba -- Martin K. Petersen Oracle Linux Engineering