Hi Martin, This patch series includes the following changes: - Split the ufshcd.h header file into two header files - one file that defines the interface with UFS drivers and another file with definitions only used in the core. - Multiple source code cleanup patches. - A few patches with minor functional changes. Please consider these changes for kernel v5.19. Thanks, Bart. Changes compared to v2: * Dropped patch 29, the patch that splits the drivers/scsi/ufs directory. Changes compared to v1: * Added a new patch with a source code comment spelling fix. * Included a HPB change in patch "Simplify statements that return a boolean". * Removed a superfluous test from patch "Remove ufshcd_lrb.sense_buffer". * Dropped patch "Remove the LUN quiescing code from ufshcd_wl_shutdown()". * Fixed indentation in patch "Make the config_scaling_param calls type safe". * Improved the description of patch "Remove locking from around single register writes". * Modified patch "Minimize #include directives" such that the current order of #include directives is preserved. * Fixed support for CONFIG_SCSI_UFS_HWMON=n in patch "Split the ufshcd.h header file". * In patch "Split the drivers/scsi/ufs directory", moved the UFS source files from drivers/scsi/ufs/ into drivers/ufs/. Bart Van Assche (28): scsi: ufs: Fix a spelling error in a source code comment scsi: ufs: Declare ufshcd_wait_for_register() static scsi: ufs: Remove superfluous boolean conversions scsi: ufs: Simplify statements that return a boolean scsi: ufs: Remove ufshcd_lrb.sense_bufflen scsi: ufs: Remove ufshcd_lrb.sense_buffer scsi: ufs: Use get_unaligned_be16() instead of be16_to_cpup() scsi: ufs: Remove the UFS_FIX() and END_FIX() macros scsi: ufs: Rename struct ufs_dev_fix into ufs_dev_quirk scsi: ufs: Declare the quirks array const scsi: ufs: Invert the return value of ufshcd_is_hba_active() scsi: ufs: Remove unused constants and code scsi: ufs: Switch to aggregate initialization scsi: ufs: Make the config_scaling_param calls type safe scsi: ufs: Remove the driver version scsi: ufs: Rename sdev_ufs_device into ufs_device_wlun scsi: ufs: Use an SPDX license identifier in the Kconfig file scsi: ufs: Remove paths from source code comments scsi: ufs: Remove the TRUE and FALSE definitions scsi: ufs: Remove locking from around single register writes scsi: ufs: Introduce ufshcd_clkgate_delay_set() scsi: ufs: qcom: Fix ufs_qcom_resume() scsi: ufs: Remove unnecessary ufshcd-crypto.h include directives scsi: ufs: Fix kernel-doc syntax in ufshcd.h scsi: ufs: Minimize #include directives scsi: ufs: Split the ufshcd.h header file scsi: ufs: Move the struct ufs_ref_clk definition scsi: ufs: Move the ufs_is_valid_unit_desc_lun() definition drivers/scsi/ufs/Kconfig | 26 +- drivers/scsi/ufs/cdns-pltfrm.c | 2 +- drivers/scsi/ufs/tc-dwc-g210-pci.c | 1 + drivers/scsi/ufs/tc-dwc-g210-pltfrm.c | 1 + drivers/scsi/ufs/tc-dwc-g210.c | 2 + drivers/scsi/ufs/tc-dwc-g210.h | 2 + drivers/scsi/ufs/ufs-debugfs.c | 1 + drivers/scsi/ufs/ufs-exynos.c | 5 +- drivers/scsi/ufs/ufs-exynos.h | 8 +- drivers/scsi/ufs/ufs-hisi.c | 2 + drivers/scsi/ufs/ufs-hwmon.c | 1 + drivers/scsi/ufs/ufs-mediatek.c | 31 +-- drivers/scsi/ufs/ufs-qcom-ice.c | 2 +- drivers/scsi/ufs/ufs-qcom.c | 28 +- drivers/scsi/ufs/ufs-qcom.h | 6 +- drivers/scsi/ufs/ufs-sysfs.c | 1 + drivers/scsi/ufs/ufs-sysfs.h | 3 +- drivers/scsi/ufs/ufs.h | 35 --- drivers/scsi/ufs/ufs_bsg.c | 6 + drivers/scsi/ufs/ufs_bsg.h | 7 +- drivers/scsi/ufs/ufs_quirks.h | 15 +- drivers/scsi/ufs/ufshcd-crypto.h | 5 +- drivers/scsi/ufs/ufshcd-dwc.c | 2 + drivers/scsi/ufs/ufshcd-dwc.h | 2 + drivers/scsi/ufs/ufshcd-pci.c | 4 +- drivers/scsi/ufs/ufshcd-pltfrm.c | 28 +- drivers/scsi/ufs/ufshcd-priv.h | 298 +++++++++++++++++++++ drivers/scsi/ufs/ufshcd.c | 232 ++++++++-------- drivers/scsi/ufs/ufshcd.h | 368 ++++++-------------------- drivers/scsi/ufs/ufshci.h | 2 + drivers/scsi/ufs/ufshpb.c | 14 +- drivers/scsi/ufs/unipro.h | 18 +- 32 files changed, 578 insertions(+), 580 deletions(-) create mode 100644 drivers/scsi/ufs/ufshcd-priv.h