Re: [PATCH v2 05/44] NCR5380: Move the SCSI pointer to private command data

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2/8/22 23:29, Hannes Reinecke wrote:
On 2/8/22 18:24, Bart Van Assche wrote:
+static inline struct scsi_pointer *NCR5380_scsi_pointer(struct scsi_cmnd *cmd)
+{
+    struct NCR5380_cmd *ncmd = scsi_cmd_priv(cmd);
+
+    return &ncmd->scsi_pointer;
+}
+

Seeing that it's open-coded at several places, maybe kill the macro entirely?

macro -> function? Anyway, although that makes type checking less strict, I will do this.

Thanks,

Bart.



[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Index of Archives]     [SCSI Target Devel]     [Linux SCSI Target Infrastructure]     [Kernel Newbies]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Linux IIO]     [Samba]     [Device Mapper]

  Powered by Linux