On 2021/05/14 7:38, Bart Van Assche wrote: > Use scsi_get_sector() instead of scsi_get_lba() since the name of the > latter is confusing. Additionally, use lower_32_bits() instead of > open-coding it. This patch does not change any functionality. > > Cc: Benjamin Block <bblock@xxxxxxxxxxxxx> > Signed-off-by: Bart Van Assche <bvanassche@xxxxxxx> > --- > drivers/s390/scsi/zfcp_fsf.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/s390/scsi/zfcp_fsf.c b/drivers/s390/scsi/zfcp_fsf.c > index 2e4804ef2fb9..3d9a3dc4975b 100644 > --- a/drivers/s390/scsi/zfcp_fsf.c > +++ b/drivers/s390/scsi/zfcp_fsf.c > @@ -2600,7 +2600,7 @@ int zfcp_fsf_fcp_cmnd(struct scsi_cmnd *scsi_cmnd) > > if (scsi_get_prot_op(scsi_cmnd) != SCSI_PROT_NORMAL) { > io->data_block_length = scsi_cmnd->device->sector_size; > - io->ref_tag_value = scsi_get_lba(scsi_cmnd) & 0xFFFFFFFF; > + io->ref_tag_value = lower_32_bits(scsi_get_sector(scsi_cmnd)); > } > > if (zfcp_fsf_set_data_dir(scsi_cmnd, &io->data_direction)) > Looks good. Reviewed-by: Damien Le Moal <damien.lemoal@xxxxxxx> -- Damien Le Moal Western Digital Research