On Fri, 2006-08-04 at 16:24 +0100, Christoph Hellwig wrote: > > + if (rkt_readl(dev, MUnit.OMRx[0]) & KERNEL_PANIC) { > > + u32 var; > > + printk(KERN_ERR "%s%d: adapter kernel panic'd.\n", dev->name, instance); > > + var = 0; > > + if ((aac_rkt_check_health(dev) <= 0) > > + || rkt_sync_cmd(dev, IOP_RESET, 0, 0, 0, 0, 0, 0, > > + &var, NULL, NULL, NULL, NULL) > > + || (var != 0x00000001) > > + || (rkt_readl(dev, MUnit.OMRx[0]) & KERNEL_PANIC)) > > + goto error_iounmap; > > + } > > I know you guys hate me for all that nitpicking, but can we write the > if condition in normal kernel style? Even better untangle it a little > and put it into a helper function: I do check for these things when looking over the patches. I guess I missed some this time. I'll fix it. -- Mark Haverkamp <markh@xxxxxxxx> - : send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html