On Wed, 2005-08-10 at 10:37 -0700, Andrew Morton wrote: > > and anyway, it doesn't have to be unique; > > set_task_comm just does a strlcpy from the name, so it will be truncated > > (same as for a binary with > 15 character name). > > Yup. But it'd be fairly silly to go adding the /%d, only to have it > truncated off again. Well, but the other alternative is that we hit arbitrary BUG_ON() limits in systems that create numbered workqueues which is rather contrary to our scaleability objectives, isn't it? I think I'd rather the name truncation than have to respond to kernel BUG()'s. If someone really has a problem with the appearance of ps, they can always increase TASK_COMM_LEN. > We could truncate the name before adding the CPU number, but it sounds > saner to just prevent anyone passing in excessively long names. Via > BUG_ON, say ;) > > What's the actual problem? What I posted originally; the current SCSI format for a workqueue: scsi_wq_%d hits the bug after the host number rises to 100, which has been seen by some enterprise person with > 100 HBAs. The reason for this name is that the error handler thread is called scsi_eh_%d; so we could rename all our threads to avoid this, but one day someone will come along with a huge enough machine to hit whatever limit we squeeze it down to. James - : send the line "unsubscribe linux-scsi" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html