On Sun, Jan 21, 2024 at 2:24 PM Andi Shyti <andi.shyti@xxxxxxxxxx> wrote: > > Hi Sam, > > > void __iomem *regs = sdd->regs; > > unsigned long val = 1; > > u32 status; > > - > > - /* max fifo depth available */ > > - u32 max_fifo = (FIFO_LVL_MASK(sdd) >> 1) + 1; > > + u32 max_fifo = FIFO_DEPTH(sdd); > > Why have you removed the comment? Perhaps you could place it on > the side in order to remove that awful space. > The fact that `max_fifo' contains max FIFO depth is already coded in the variable name itself. And with that new FIFO_DEPTH() macro, it would be basically stating the same thing the third time on the same string. Thought the removal of that comment only made the code easier to read. If you think I should bring the comment back, please let me know and I'll send v2. > Not a biding comment, though: > > Reviewed-by: Andi Shyti <andi.shyti@xxxxxxxxxx> > > Andi