> > +static int exynosauto_ufs_post_hce_enable(struct exynos_ufs *ufs) { > > + struct ufs_hba *hba = ufs->hba; > > + > > + /* Enable Virtual Host #1 */ > > + ufshcd_rmwl(hba, MHCTRL_EN_VH_MASK, MHCTRL_EN_VH(1), MHCTRL); > > + /* Default VH Transfer permissions */ > > + hci_writel(ufs, 0x03FFE1FE, HCI_MH_ALLOWABLE_TRAN_OF_VH); > > How about using a defined macro instead of constant value, 0x03FFE1FE for > code readability? And maybe 0x03FFE1FE to 0x3FFE1FE. When I saw the value first time, I also thought it should be defined as macro but there are too many bits(26) to be described and I felt no one controls it from the default value. I'll try to use macro or at least documentation by comment next patch. Thanks. Best Regards, Chanho Park