On Fri, Apr 27, 2018 at 12:31:38AM +0200, Peter Rosin wrote: > The .owner will be handy to have around. > > Signed-off-by: Peter Rosin <peda@xxxxxxxxxx> > --- > drivers/gpu/drm/drm_bridge.c | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/drivers/gpu/drm/drm_bridge.c b/drivers/gpu/drm/drm_bridge.c > index 9f023bd84d56..a038da696802 100644 > --- a/drivers/gpu/drm/drm_bridge.c > +++ b/drivers/gpu/drm/drm_bridge.c > @@ -115,6 +115,9 @@ int drm_bridge_attach(struct drm_encoder *encoder, struct drm_bridge *bridge, > if (!encoder || !bridge) > return -EINVAL; > > + if (WARN_ON(!bridge->owner)) > + return -EINVAL; I think conceptually this is checked at the wrong place, and I think also misnamed a bit. The ->owner is essentially the struct device (and its associated driver) that provides the drm_bridge. As such it should be filled out already at drm_bridge_add() time, and I think the check should be in there. For driver-internal bridges it might make sense to also check this here, not sure. Or just require all bridges get added. Wrt the name, I think we should call this pdev or something. ->owner usually means the module owner. I think in other subsystems ->dev is used, but in drm we use ->dev for the drm_device pointer, so totally different thing. pdev = physical device is the best I came up with. Better suggestions very much welcome. -Daniel > + > if (previous && (!previous->dev || previous->encoder != encoder)) > return -EINVAL; > > -- > 2.11.0 > > _______________________________________________ > dri-devel mailing list > dri-devel@xxxxxxxxxxxxxxxxxxxxx > https://lists.freedesktop.org/mailman/listinfo/dri-devel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html