On 07.05.2014 22:47, Ajay kumar wrote:
Tomasz,
On Thu, May 8, 2014 at 2:04 AM, Tomasz Figa <tomasz.figa@xxxxxxxxx> wrote:
Hi Ajay,
On 07.05.2014 14:56, Ajay Kumar wrote:
Add PWM backlight node for exynos5250 and enable the same on exynos5250
based snow board.
Signed-off-by: Olof Johansson <olof@xxxxxxxxx>
Signed-off-by: Ajay Kumar <ajaykumar.rs@xxxxxxxxxxx>
---
arch/arm/boot/dts/exynos5250-pinctrl.dtsi | 7 +++++++
arch/arm/boot/dts/exynos5250-snow.dts | 5 +++++
arch/arm/boot/dts/exynos5250.dtsi | 10 ++++++++++
3 files changed, 22 insertions(+)
diff --git a/arch/arm/boot/dts/exynos5250-pinctrl.dtsi
b/arch/arm/boot/dts/exynos5250-pinctrl.dtsi
index 9a49e68..2a4680c 100644
--- a/arch/arm/boot/dts/exynos5250-pinctrl.dtsi
+++ b/arch/arm/boot/dts/exynos5250-pinctrl.dtsi
@@ -351,6 +351,13 @@
samsung,pin-drv = <0>;
};
+ backlight_pwm: backlight-pwm {
+ samsung,pins = "gpb2-0";
+ samsung,pin-function = <2>;
+ samsung,pin-pud = <0>;
+ samsung,pin-drv = <0>;
+ };
This looks like a generic PWM output function, not specific to backlight in
any way.
Please see patch [1] adding PWM output pin groups for Exynos5420 for
reference.
[1]
https://www.mail-archive.com/linux-samsung-soc@xxxxxxxxxxxxxxx/msg29869.html
Right! I just referred to the manual again, and it actually reads TOUT_0.
So, I should be probably renaming this as "pwm0_out" like in the other patch?
Yes, please. You should also add remaining ones, while at it. Basically
same patch as [1] but for Exynos5250.
Best regards,
Tomasz
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html