On Tue, Sep 13, 2016 at 03:10:39AM +0900, Masahiro Yamada wrote: > The combo of list_empty() check and return list_first_entry() > can be replaced with list_first_entry_or_null(). > > Signed-off-by: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> > --- > > arch/s390/kernel/crash_dump.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 deletions(-) > > diff --git a/arch/s390/kernel/crash_dump.c b/arch/s390/kernel/crash_dump.c > index 29df848..621907d 100644 > --- a/arch/s390/kernel/crash_dump.c > +++ b/arch/s390/kernel/crash_dump.c > @@ -71,9 +71,8 @@ struct save_area * __init save_area_alloc(bool is_boot_cpu) > */ > struct save_area * __init save_area_boot_cpu(void) > { > - if (list_empty(&dump_save_areas)) > - return NULL; > - return list_first_entry(&dump_save_areas, struct save_area, list); > + return list_first_entry_or_null(&dump_save_areas, struct save_area, > + list); Applied, however without the line break in order to improve readability. Thanks! -- To unsubscribe from this list: send the line "unsubscribe linux-s390" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html