On Wed, 2007-08-01 at 11:19 -0400, Gregory Haskins wrote: > On Wed, 2007-08-01 at 08:10 -0700, Daniel Walker wrote: > > > > > rt_mutex_setprio() is just a function. It was also designed specifically > > for PI , so it seems fairly sane to use it in other PI type > > situations .. > > > > Yes. It is designed for PI and I wasn't suggesting you shouldn't use > the logic itself. What I was suggesting is that dealing with an API > that has "rt_mutex" in it for something that has nothing to do with > rt_mutexes is, well... It's fine for now .. One step at a time.. > All I was suggesting is that we break out the PI subsystem from rt_mutex > code so its an independent PI API and have the rt_mutex subsystem become > a user. That's a far cleaner way to do it, IMHO. The workqueues don't really need full blown transitive PI. So without that your back to the rt_mutex_setprio function .. Which could be renamed .. Here was my attempt years ago , http://lkml.org/lkml/2005/5/31/288 Looking back on it, I'm not sure what users I was planning to implement along with it .. I'm sure I was thinking "There must be other blocking primitives that could use this.." , but now I don't think there are .. Everything pretty much runs through the rt mutex.. workqueues are just "dancing" , or changing priorities up/down which is really only the lowest level of what the rt-mutex does. Daniel - To unsubscribe from this list: send the line "unsubscribe linux-rt-users" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html