Hi Geert, > > @@ -952,6 +952,16 @@ static inline u8 i2c_8bit_addr_from_msg(const struct i2c_msg *msg) > > return (msg->addr << 1) | (msg->flags & I2C_M_RD); > > } > > > > +static inline u8 i2c_10bit_addr_from_msg(const struct i2c_msg *msg) > > Having never used 10-bit addressing myself, or even looked into it, > it took me a while to understand what this helper really does... > So this returns the high byte of the artificial 16-bit address that > must be used to address a target that uses 10-bit addressing? > Hence I think this should be renamed, to better match its purpose. It's coherent with i2c_8bit_addr_from_msg(), right? Andi