Schemas should be OS agnostic, so don't mention what the "I2C core" will do because this only applies to Linux. Also, drop the generic "smbus_alert" naming because this belongs to controllers not targets, so we don't want to describe it here. Signed-off-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> --- dtschema/schemas/i2c/i2c-controller.yaml | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/dtschema/schemas/i2c/i2c-controller.yaml b/dtschema/schemas/i2c/i2c-controller.yaml index e475ead..7eb6b0f 100644 --- a/dtschema/schemas/i2c/i2c-controller.yaml +++ b/dtschema/schemas/i2c/i2c-controller.yaml @@ -171,8 +171,8 @@ patternProperties: interrupts: description: - I2C core will treat "irq" interrupt (or the very first interrupt if - not using interrupt names) as primary interrupt for the target. + If not using interrupt-names, the first interrupt will be treated as + the primary interrupt for the target. interrupt-names: anyOf: @@ -181,10 +181,10 @@ patternProperties: enum: - irq - wakeup - - smbus_alert description: - Names which are recognized by I2C core, other names are left to - individual bindings. + Generic names are "irq" for the primary interrupt and "wakeup" + for the wakeup interrupt. Other names are left to individual + bindings. wakeup-source: description: -- 2.43.0